SharePointCommunity
Die deutschsprachige Community für SharePoint, Office 365 und mit Azure

Fehler ContentViewer-Webpart

bewertet von 0 Usern
Nicht beantwortet Dieser Beitrag hat 0 Geprüfte Antworten | 2 Antworten | 1 Follower

Top-500-Beitragsschreiber
34 Beiträge
Schmidt Mathias erstellt in 1 Okt 2018 13:42

Hallo,

Ich habe ein Webseite mit einem eingebunden ContentViewer-Webpart. Dieses zeigt Inhalte aus einer anderen SiteCollection der gleichen SharePoint-Farm an. Das funktioniert soweit ganz gut, solange ich über die Default-URL zugreife. Erfolgt der Zugriff jedoch über einen alternativen Pfad wird die src im iFrame immer auf den Default-Name geschrieben. 

Ich habe mir mal den Content des Webpart in der PowerShell anzeigen lassen. Dieses beinhaltet dort jedoch nur relative Urls. 

Gibt es eine Möglichkeit das iFrame des ContenViewer auch mit alternativen Hostnamen zu nutzen?

In allen anderen Sachen funktioniert das Alternative Access Mapping korrekt.

 

Alle Antworten

Top-10-Beitragsschreiber
18.855 Beiträge

Versuche es doch einfach mal mit einem Script-Editor-Webpart, in das Du einfach manuell den <iframe> einsetzt.

Viele Grüße
Andi
af @ evocom de
Blog
Top-500-Beitragsschreiber
34 Beiträge

Danke für die Antwort. Das werde ich mal testen. Leider ist es es in meinem Fall eine aufwendige Option, da sich mein Problem über ca 500 Teamseiten ersteckt.

Das Webpart wird mittels einer selbstentwickelten SharePoint Lösung (c#) inkl. Teamseitenvorlage erstellt. Diese wurde vor mehreren Jahren durch einen Kollegen erstellt und trotz bedenken auf der SharePoint Farm veröffentlicht. Leider ist dieser Entwickler nicht mehr greifbar. 

Falls der Vorschlag funktioniert hieße das ich muss die Lösung daraufhin anpassen und alle vorhandenen Teamseiten per Script daraufhin abändern. :'( So einen Aufwand wollte ich eigentlich vermeiden.

 

 

Seite 1 von 1 (3 Elemente) | RSS