SharePointCommunity
Die deutschsprachige Community für SharePoint, Office 365 und mit Azure

Upgradefehler der MySite-DB

bewertet von 0 Usern
Nicht beantwortet Dieser Beitrag hat 0 Geprüfte Antworten | 0 Antworten | 1 Follower

Top-25-Beitragsschreiber
383 Beiträge
Derby erstellt in 11 Jan 2018 13:38

Das  Upgraden einer MySite-DB von 2010 über 2013 nach 2016 scheitert beim Schritt nach 2016 die DB lässt sich nicht in einen Ordnungsgemäßen Zustand bringen. Problem ist hier wohl das Feature 'SocialDataStore' (Id: 15/'fa8379c9-791a-4fb0-812e-d0cfcac809c8' was nicht ordentlich geupgraded wird. Sichtbar wird der Fehler das die DB im Zustand "Die Datenbank ist aktuell, das Upgrade einiger Websites ist jedoch noch nicht vollständig." steht und das die Blogseiten einige Webpartfehler (Archiv) aufweisen. Weiterhin sind zahlreiche "Serverseitige Abhängigkeiten fehlen" im HealthAnalyzer vorhanden. Wird nach der Migration eine neue Blogseite angelegt, hat diese keine Probleme mit den Webparts.

Auszug aus dem Upgrade-Log.

01/11/2018 11:31:37.03 powershell (0x11BC) 0x2D00 SharePoint Foundation Upgrade SocialDataStoreFeatureReceiver ajx0s ERROR SocialDataStoreFeatureReceiver.FeatureUpgrading(http://mysite2.****) FAILED: System.ArgumentException: Der Wert liegt außerhalb des erwarteten Bereichs.     bei Microsoft.SharePoint.SPListTemplateCollection.get_Item(String strName)     bei Microsoft.SharePoint.Portal.SocialDataStoreFeatureReceiver.CreateSitesDocumentsView(SPWeb web)     bei Microsoft.SharePoint.Portal.SocialDataStoreFeatureReceiver.FeatureUpgrading(SPFeatureReceiverProperties properties, String upgradeActionName, IDictionary`2 parameters) 0c6f3f9e-6e51-a037-2239-d474c12d373d
01/11/2018 11:31:37.03 powershell (0x11BC) 0x2D00 SharePoint Foundation Upgrade SPFeatureDefinition aj2bj ERROR Feature upgrade action 'CustomUpgradeAction.CreateSitesDocumentsView' threw an exception upgrading Feature 'SocialDataStore' (Id: 15/'fa8379c9-791a-4fb0-812e-d0cfcac809c8') in Site 'http://mysite2.****': Der Wert liegt außerhalb des erwarteten Bereichs. 0c6f3f9e-6e51-a037-2239-d474c12d373d

Einzige Möglichkeit die DB in einen Ordnungsgemäßen Zustand zu bringen, ist auf allen Seiten das Feature zu deaktivieren/aktivieren. Was aber nicht das Problem mit den Webparts behebt.

Das Problem mit dem Feature/Webpart besteht in der 2013er Farm nicht, dort wird alles sauber migriert und angezeigt. Erst in 2016 gibt es die Fehler.

Hat jemand ne Idee dazu? Ich finde praktisch nichts zu diesem Feature.

Seite 1 von 1 (1 Elemente) | RSS